现在的位置: 首页 > IT运维 > 正文

ubuntu云输入法ibus cloud pinyin

2010年09月07日 IT运维 ⁄ 共 2525字 评论数 2 ⁄ 被围观 8,715+

在我的博文《ubuntu安装搜狗云输入法》中介绍了ubuntu下搜狗云输入法的安装,ubuntu下搜狗云输入法的进化版本ubuntu云输入法ibus-cloud-pinyin已经出现,以下是安装笔记:

1、先升级ibus到1.3.7,对云输入法可能非必要,但升级后可以安装的输入法比较多。

wget http://ibus.googlecode.com/files/ibus-1.3.7.tar.gz
tar zxf ibus-1.3.7.tar.gz 
cd ibus-1.3.7
make
sudo make install

在安装期间可能会碰到很多错误,导致无法编译通过,一下是每个错误对应的解决方法:

configure: error: Your intltool is too old.  You need intltool 0.35.0 or later.
   sudo apt-get install intltool
ERROR: No package \'gtk+-2.0\' found
   sudo apt-get install libgtk2.0-dev
ERROR: No package \'dbus-1\' found
   sudo apt-get install libdbus-1-dev
ERROR: No package \'gconf2\' found
   sudo apt-get install libgconf2-dev

安装完成后,做如下步骤,会触发系统更新,更新完成后,ibus才正式升级完成。不过我不知道为什么要这样做,还是说步骤上有多余,大家如果有测试出完整正确的安装步骤的还请告知,谢谢!

sudo add-apt-repository ppa:shawn-p-huang/ppa
sudo apt-get update
sudo apt-get install ibus-gtk ibus-qt ibus-pinyin ibus-pinyin-db-open-phrase

2、云输入法安装

svn checkout http://ibus-cloud-pinyin.googlecode.com/svn/trunk/ ibus-cloud-pinyin-read-only
cd ibus-cloud-pinyin-read-only
make
sudo make install

同样,在安装过程中,会遇到错误,错误及对策如下:

ERROR: Required program valac not found
  sudo apt-get install valac
ERROR: Required program lua not found
  sudo apt-get install lua5.1-0-dev
ERROR: Required program sqlite3 not found
  sudo apt-get install libsqlite3-dev
ERROR: Required pkg lua5.1 >= 5.1 not found
ERROR: Required pkg gee-1.0 >= 0 not found
  sudo apt-get install libgee-dev
ERROR: Required pkg dbus-glib-1 >= 0 not found
  sudo apt-get install dbus-glib-1-dev
ERROR: Required pkg libnotify >= 0 not found
  sudo apt-get install libnotify-dev
ERROR: Runtime-required luasocket not found
  sudo apt-get install luasocket5.1-socket2
另外可能需要安装的包 : compiz-dev libgtk2.0-dev

3、配置方法

如果需要更改默认配置,目前的版本需要手工修改配置文件:

全局配置文件:/usr/share/ibus-cloud-pinyin/lua/config.lua

用户配置文件:${XDG_CONFIG_HOME:-$HOME/.config}/ibus/cloud-pinyin/config.lua

修改完配置后,记得将配置项周围的注释--[[ 和 --]]删除

sudo gedit /usr/share/ibus-cloud-pinyin/lua/config.lua
set_switch{
	default_chinese_mode = true,
	default_offline_mode = false,
	default_traditional_mode = false,
	double_pinyin = true,
	background_request = true,
	show_raw_in_auxiliary = true,
	always_show_candidates = true,
	show_pinyin_auxiliary = true,
}

error

main.vala:28.7-28.22: error: The name `thread_init\' does not exist in the context of `DBus\'
      DBus.thread_init();
Compilation failed: 1 error(s), 0 warning(s)
make[1]: *** [main.c] 错误 1

http://live.gnome.org/Vala/Release

wget http://download.gnome.org/sources/vala/0.10/vala-0.10.2.tar.bz2
tar jxf vala-0.10.2.tar.bz2
cd vala-0.10.2
./configure
make && make install
sudo ln -s /usr/local/lib/libvala-0.10.so.0.0.0 /usr/lib64/libvala-0.10.so.0
#if need flex
sudo apt-get install flex

最新更新:

Updates

    * 2010.11.24 消除编译时 libgee 警告,一个其他小改进 

目前有 2 条留言 其中:访客:1 条, 博主:1 条

  1. echelon : 2010年11月30日20:48:27  -49楼

    已经安装了liblua5.1-0-dev,确仍然显示ERROR: Required program lua not found。怎么办?

给我留言

您必须 [ 登录 ] 才能发表留言!

×
#